Description of the need
I've gotten bitten a few times when file ownership or permissions gets set incorrectly on config/active such that the active configuration directory isn't writable. Since some modules still incorrectly store states in config instead of in the states storage system, that can lead to surprisingly broken sites with entire pages failing to load and displaying "Failed to write configuration file" errors.
Proposed solution
I suggest adding a check to make sure that the active configuration directory is writable to the system requirements function. That would display an alert on the Backdrop status page and could easily be detected by monitoring systems.
Alternatives that have been considered
I'm going to work on adding this check to our sites via a custom module, but this seems like an issue universal enough to merit addition to core.
Recent comments
Thanks, the /tmp folder was the problem. I moved it elsewhere and then the updated worked. Thanks again!
Update 1.35.1 appears to install but hasn't
Probably not the reason, but worth to do a quick check: Sometimes the update cache interferes, so if something's odd with updates - some module (or core) claims to have updated, but then...
Update 1.35.1 appears to install but hasn't
Nope, not touched any permissions!
Update 1.35.1 appears to install but hasn't