Description of the need We have this problem on Pantheon with the installer module: If the site is not in SFTP mode, then the installer can't install.
We know that the installer can't install, so when we try to install something, we throw a nice error saying that there's a permissions issue.
Proposed solution Why don't we use this check as a dependency for the installer module? If you can't write modules to your filesystem, then you can't use this module.
Recent comments
Thanks, the /tmp folder was the problem. I moved it elsewhere and then the updated worked. Thanks again!
Update 1.35.1 appears to install but hasn't
Probably not the reason, but worth to do a quick check: Sometimes the update cache interferes, so if something's odd with updates - some module (or core) claims to have updated, but then...
Update 1.35.1 appears to install but hasn't
Nope, not touched any permissions!
Update 1.35.1 appears to install but hasn't