Not sure why I'm having a problem on such a seemingly simple thing. I have defined node/2 as the front page and the Home breadcrumb goes there. I manually created my menu with some links. I then went to Structure --> Layouts --> Home page --> Manage blocks and added the block named for my menu in the main content region. I tried both without a visibility spec (it's the home page payout, right?) as well as with a "Is home page" condition. Neither way do I see my menu on the front page. One thing: clean urls is not enabled - need to talk to company sysadmin about that. But it's the home page, so wouldn't think that would be an issue. Any ideas?


Your not wrong. This is confusing. 

I don't think I have run into this before, but I can see that when you specify node/2 as the home page (here: admin/config/system/site-information), then the home page becomes node/2 using the default layout (Backdrop uses the default layout for nodes out of the box, but you can add a custom layout for nodes) NOT the homepage layout. 

In a sense, when you change the home page on admin/config/system/site-information, you are actually choosing to NOT use the default layout template for home page. 

I have to think a bit more about why this is AND how we can make this less confusing. 

In the meantime, one alternative solution would be for you to add a NODE BLOCK to the home page layout instead of redirecting to the node directly. 

1) Go to admin/structure/layouts/manage/home

2) "Add block" = "Existing Content"

3) Configure existing content block

This will display your specific node content on the default HOME layout.

I suspect that the reason for this confusion is that the original home page setting on admin/config/system/site-information existed before Backdrop CMS implemented our current layout system and that we just haven't dealt with the conflict yet. 



Thanks, I assumed of course that the home page layout applied to whatever page/url I defined as the home page in site info config. Now I'm wondering how I turn off the menu block title. Since it isn't a custom block, I don't see a place to enter <none> for the title.

I added a Primary Menu block to my header. This would be the default menu block provided by core. I am not noticing that any "Title" is displaying. If I try to edit the block, I see this option = "Block title Type." 

Mine is set to default and no title is showing, but there is also a "none" option. Do you have this available? Does it do what you need?