I have an error question but first I would like to say how much I like backdrop! About a year ago I moved our town website to Backdrop. It had been running on versions of Drupal over the years which have worked well. Backdrop is just move consumer friendly and I like thought of not having to rebuild the site every several years.

There has been a request for a discussion forum on our site (Backdrop 1.12.4) so I made the easy install of the forum module (1.x-1.0.1).

When logged in as administrator I can add a new forum topics but when logged in as just a registered user I get the error message "The website encountered an unexpected error. Please try again later" when trying to add a new topic. I've tried it on two different servers and get the same error. Under "Resent log messages" there are two errors:

1. "PHP EntityStorageException: SQLSTATE[HY000]: General error: 1366 Incorrect integer value: '' for column 'sticky' at row 1 in NodeStorageController->save() (line 320 of /var/www/html/concord/core/modules/node/node.entity.inc). "

2. "node PDOException: SQLSTATE[HY000]: General error: 1366 Incorrect integer value: '' for column 'sticky' at row 1: INSERT INTO {forum_index} (nid, title, tid, sticky, created, comment_count, last_comment_timestamp) VALUES (:db_insert_placeholder_0, :db_insert_placeholder_1, :db_insert_placeholder_2, :db_insert_placeholder_3, :db_insert_placeholder_4, :db_insert_placeholder_5, :db_insert_placeholder_6); Array ( [:db_insert_placeholder_0] => 105 [:db_insert_placeholder_1] => test [:db_insert_placeholder_2] => 11 [:db_insert_placeholder_3] => [:db_insert_placeholder_4] => 1552941735 [:db_insert_placeholder_5] => 0 [:db_insert_placeholder_6] => 1552941735 ) in forum_field_storage_pre_insert() (line 497 of /var/www/html/concord/modules/forum/forum.module)."

The following role permissions are checked for AUTHENTICATED user:

View comments
Post comments 
Skip comment approval
Use the Filtered HTML text format
View published content
Forum topic: Create new content
Forum topic: Edit own content
Forum topic: Delete own content

Would anyone have any ideas as to what I have setup wrong or where I might look for the problem?



klonos's picture

Hello @Dkonle,

Thanks for taking the time to report this, and sorry that this is giving you a hard time.

It seems to me that this is more like a problem with the Forum module itself rather than something you are configuring wrong. If I were you, I'd file a ticket for this in https://github.com/backdrop-contrib/forum/issues.

Having said that, it seems to me that this module has not seen any love for a couple of years, and we seem to be using a custom forum module for this site here. So I have posted a question re this here: https://github.com/backdrop-contrib/forum/issues/7 ...curious to see the responce.