Hello, everybody,

I have installed mailchimp module on Backdrop but I can't activate it in the administration board.

I can't uninstall it either, nor install it by uploading .zip file.

Backdrop is behind Yunohost. Is it possible to remove mailchimp with command lines and if so, how ?

Thank you to anyone having a clue.

JP

Comments

What happens when you try to uninstall through the UI at admin/modules/list?  

Hi, angiepiano,
Thanks a lot for your prompt answer.

If you mean Backdrop UI, I don't know how to access it.

I can access my server (a raspberry pi 3B+)

I find a directory /var/www/backdrop/modules/mailchimp

****@******:/var/www/backdrop/modules/mailchimp# dir
LICENSE.txt    config          mailchimp.info      mailchimp.module
README.md      includes          mailchimp.install      modules
composer.json  mailchimp.api.php  mailchimp.make.example
 

If I apt purge from root or /var/www/backdrop/modules/mailchimp or /var/www/backdrop/modules

I get this:

apt purge mailchimp
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
E: Unable to locate package mailchimp

with apt install mailchimp:

apt install mailchimp
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
E: Unable to locate package mailchimp

Any clue?

Ta

 

Hi JP. It seems to me that you don't know much about the basics of installing a module in Backdrop (which is almost the same in Drupal 7).

The Backdrop UI contains ways to install and uninstall modules. Uninstalling a module through the UI does not remove the module folders from the server directory. It simply tells Backdrop not to load those PHP files. There is no need to remove the folders. In fact, if you remove them and Mailchimp is already installed in your Backdrop site, it will probably generate errors.

You access the Backdrop backend UI through the admin menu when visiting your site as admin. See image. The Module install UI is located at Functionality > List modules

There was a new release of the Mailchimp module yesterday. That module has not been thoroughly tested recently, so it may or may not work.

Good luck.   

 

Hi, argiepiano,

I accessed many times this UI, the problem is that I just can't activate anything once I get there. I can't tick anything. Boxes are just inactive.

Image below.

So, what else can I do?

Cheers

OK, here are some explanations/directions

- Those boxes are gray because you are missing required modules. You can't enable Mailchimp unless you download and enable those modules

- Second: you have an old version of Mailchimp. You need to download the newest version. To do that:

  • REMOVE the folder modules/mailchimp from your web server directory (you can use the linux command rm mailchimp -r).
  • Then go back to your site and go to Functionality > Install new modules and install (from within the site) Mailchimp. This will download the latest version AND the dependencies needed to enable the module

After this you should be able to enable the module. 

Once again: there is no guarantee that Mailchimp, even the latest version, will work on your site. It's a module that was pretty much abandoned 

Two things. 

Because of your issue, we've been working to make some changes to this module, because it was dependent upon a module which has now been merged into core. 

You are unable to enable Mailchimp, because is has a dependency on Entity Metadata Wrapper (a module that is no longer necessary). Normally, you would need to load and enable that module first, before you can enable Mailchimp. 

BUT, we have updated the Mailchimp module to remove that dependency, so will need to upgrade Mailchimp first. 

As argiepiano mentioned, this module needs more testing. So, even after updating the module you might encounter problems. Please, report them here. 

But, next step is to try updating the module. You should be able to do this through the User Interface (UI) at admin/reports/updates/list

Let us know how that goes.

(It seems argiepiano and I were working at the same time. :-)