I have created a content type with title, body, and two image fields. One of the image fields has "Number of values" set to unlimited.  When trying to add a new node I am able to select an image and it gets uploaded automatically.  I can select an image for the second field but I have to save the node first to have the second image uploaded. Once the node is saved the image upload for both image fields works as expected.  Any idea how to resolve this?


I tried to recreate this on a fresh Backdrop CMS 1.15 site. 

I'm finding that the second image field is not showing a thumbnail of my uploaded image, but if I save the node. The second field is uploading and displaying and when I reopen the node, the thumbnail is present. 

I tried this with two image fields set to one image each. And I tried it with the first image field set to `unlimited` and the second limited to just one image (as shown).

Can you recreate this problem on a new fresh site or provide additional steps to recreate the problem?

It might be that something else specific to your site is causing the problem. 

OK, I did a little extra testing and see where this leads to a greater problem. In your case, where one field allows for multiple images, you can only upload one new image - IF, you already uploaded an image to another field first. 

However, if you add images to the multi-image field first, you can upload all your images immediately, even though not all of them will show the thumbnails. If you have multiple image fields that allow for more than one image each, you will probably not be able to upload all your images, without multiple saves. 

I'm reporting this bug in the core issues queue.


It would be great if you could add your own thoughts or details to the github issue. The more information we have, the easy to fix this bug. Also, the more people who comment on an issue, the more likely it is to get attention and fix.

In the meantime, be sure to add images to your multi-image field first. :-(

Rogelio's picture

i can confirm this, but this not only with unlimited, in my case it happens with any values in the other image field

Same problem with previous version 1.14.3 

This bug seems to be still present. For some projects this might be a real show stopper. Are there any plans addressing this issue?

@limas - Thanks for the reminder. We do have an open issue:

Unfortunately, sometimes issues like this fall off the radar screen if core contributors are not getting any feedback on them.

I suspect that happened in this case. It's ok to post a comment in the core issue queue asking about progress or simply reporting that you are still experiencing the problem. Sometimes this can jump start a stalled issue.

I'll post a comment there now. If you have any additional information that might help move the issue along, that is also helpful.