diannevolek's picture

My Status report says my PHP version is 5.6. When I check the phpinfo on Backdrop it also says PHP Version 5.6.40

On my reseller hosting I have set the domain to have PHP7.4.  It allows me to set the Domain name, but not the "Home Directory".

The PHP.INI file in both public_html (plus a copy one level higher) has the following.

display_errors = Off
max_execution_time = 60
max_input_time = 60
max_input_vars = 1000
memory_limit = 256M
post_max_size = 8M
session.gc_maxlifetime = 1440
session.save_path = "/var/cpanel/php/sessions/ea-php74"
upload_max_filesize = 5M
zlib.output_compression = Off
extension_dir = "ext"

Is there any OTHER way I can set the PHP version. I have also asked the service provider. But I do have some D7 sites stuck on 7.0. (not sure why, but they stop working if it's set higher)/


I suspect that you will need the help of the hosting provider to resolve this. Changing PHP versions is usually a server admin task, unless they provide you with an option in the Control Panel. But, it sounds like you have tried the control panel already, so I think you will need help from server admin to sort this out. 

I look forward to hearing what they have to say about the problem.

But Backdrop says not. (see domain at the top)

I wouldn't worry, except I'm getting some strange things happening.

For example on my modules, the "search" doesn't work? I duplicated the site and I'm using the same browser.

This also can't access Update Data. There might be other reasons, but perhaps it's the PHP version. The fact that 5.6 works is impressive!


My Service provider reverted the account back to 5,6, then redid the 7.4 and it changed!

Solutions are so simple when you know the answer! Maybe it will work for others on shared hosting!