Apparently the latest update (to 1.13.3) ruined the ability to install backdrop in another language. It worked ok in previous version.

I am using Danish.

There is no other language other than english no matter what I do before install. Installing Danish .po file (etc.) after install doesn't worh either . nothing gets translated (yes I clear cache etc.).

Any ideas?

Most helpful answers

Hello Egmund,

please go to admin/config/regional/language and disable "English", then clear caches.

Problem seems like you have two language site without properly set up languages management. 

Comments

Sorry, I don't have an answer for you. But, if something worked in Backdrop and then it doesn't, you should probably report that in the core issue queue on Github. 

https://github.com/backdrop/backdrop-issues/issues

Anyone can (and SHOULD) report bugs/issues in the issue queue. Development priorities are set in the issue queue and the sooner a bug gets reported the quicker is likely to get fixed. 

Hello Egmund,

please go to admin/config/regional/language and disable "English", then clear caches.

Problem seems like you have two language site without properly set up languages management. 

I want a one-language site - Danish. That should be possible. I followed the 'guide' uploading the .po file to both files/translations and files/languages but the choice doesn't show up - only 'English'.

I erased everything and started over since adding language after install didn't work.

Potential system installation bug is installing English as additional language when user select another languages.

I did clean install using .po files from Drupal placed to files/translations and have option select from provided languages plus English. After finish non-English install I find my site have two enabled languages, one of them is English, but site is not configured for multi-language behavior, e.g. detecting/selecting and so on. Disabling then removing English from languages list is possible solution for creating non-English one-language site.

 

Thank you findlabnet,

I installed in English since no other options are there, followed your suggestion to disable English after adding Danish and clearing the cache. It worked - seems to be in all Danish now.

But I do not think this is how it worked in previous versions. I did not have to disable English and I had the option of installing in danish.

>> since no other options are there

But I have other options (.po files was placed to files/translations before start install).
Maybe files permissions (web server cannot read them) is an issue?

Just in case - I've used Drupal's .po files with another name pattern - so seems it resolved on Github.

Yes, you are right. I used a Drupal .po last time (there were no backdrop danish .po files then). Mystery solved.