I know Rules already from Drupal 7 but it is not about an upgrade but in a newly installed Backdrop I have set

After saving new content


Content is published
Parameters: Content: [node]

Content is promoted to frontpage
Parameters: Content: [node]


Send mail to all users of a role

rules settings

And now comes the problem, because different from Drupal 7:

In the field ...

Select the roles whose users should receive the mail.

... I can only select 'Editor' and 'Administrator', but not 'Authenticated'.

editing action

Why? Also the authenticated users are registered with email addresses and should be notified.

Translated with www.DeepL.com/Translator

Rules 1.x-2.3.2
Backdrop 1.23.0
PHP 8.1.7
Firefox 106










I get the same.  Not sure if this is intentional or not, but as an alternative solution you could use rules to give each new account a special role, perhaps called AuthenticatedPlus or something more descriptive and just use it for this.

indigoxela's picture

Hi Heiner,

same here...

The odd thing is that Rules for B uses function entity_plus_metadata_user_roles() instead of user_roles() right away.

It's probably best to ask in the Rules modules's issue queue, what the intention behind that is.

For what is worth, Drupal 7 has exactly the same functionality - so, this is by design. You can read a discussion about this here, in the D7 Rules issue queue. This happened 10 years ago, and a "fix" was never implemented, so I'm guessing there is a good reason for that (I haven't read the queue in detail).

In any case, it would be pretty straightforward to create a custom action to send email to authenticated users. Keep in mind that "authenticated" includes also users with all the other roles listed in the UI.  

So many responses, it made me happy: thanks for your advice!

But I would like to tell you about a workaround we discovered:



we created a new, additional role (with its own, arbitrary name) and gave it all the rights that 'Authenticated' actually has.

And this role is now displayed in the settings at


recognized. So the goal is reached for the time being.

Greetings, Heiner

Translated with DeepL.com





That's great, Heiner! I'm glad you found a workaround. It may be worth opening an issue in the Rules queue anyway, to see if the real "authenticated" user can be added to the list.