In local MampPro setup, attempted to run update.php to update core to 1.18.3 but returned blank page, no progress bar shown. Looked at /admin/reports/dblog there is no error.

Tried on two separate relatively fresh test setups the update ran smoothly. One thing I noted is this problematic one I have civicrm dbase setup separately. It's the same dbase user with ID/PW root/root. php ini settings are default.

Also attempted to edit php ini template file to memory_limit = 512M; max_execution_time = 600; max_input_time = 600; post_max_size = 256M; upload_max_filesize = 256M but same blank screen.

One next thing I haven't tried is to use drush to update, but I'm still figuring out how to set this up. 

What other possible areas could have caused the blank screen? Appreciate any advice. Thank you!



klonos's picture

Hello ??

I am not using MampPro nor CiviCRM, so I cannot be of much help in that front, but if you cannot access the admin UI, you could try adding the following line in your settings.php file:

$config['system.core']['error_level'] = 'all';

What that basically does is to set the "Error messages to display" setting under Development -> Logging and errors to "All messages". Perhaps that would help show a useful error 🤷‍♂️

Hi klonos, thanks for the suggestion. I've already set to show "All messages" in admin/config/development/logging earlier. Nonetheless I still add that line into settings.php, but still return blank page. 🤔

indigoxela's picture

Hi blimking,

I never used MampPro, but I assume that it has some error logfiles. If you figure out, where the logfiles are, you maybe find some log entries that explain what went wrong.

To make sure: your local Backdrop install worked without problems before?

And you didn't change anything regarding the setup?

If it's really a completely white page (also known as WSOD - white screen of death), then something weird is going on. The reason for WSOD is usually something severe (missing functions or classes, broken code...).

One other thing would be helpful: which Backdrop version was your previous one?

From 1.18.2 to 1.18.3 there's no update.php run needed, so I assume, your Backdrop is an older version - which one?

Hi indigoxela, thanks for the help. Yes I've looked into those log files, but seems nothing related to this issue...

  1. apache_error.log > the usual startup [notice] type of msg
  2. mysql_error.log > has [Warning] InnoDB: Table mysql/innodb_index_stats has length mismatch in the column name table_name.  Please run mysql_upgrade. But this one been there since a long time ago doesn't seem to affect my other sites.
  3. php_error.log > nothing new since the last msg 3 weeks ago

I have several same project Backdrop instances, some by itself, some with civicrm added. I've updated them all from 1.18.1 to 1.18.3 via UI no issue. The ONLY difference is this one I had the civicrm using a SEPARATE dbase.

Earlier I used Backup & Migrate to backup both dbases no issue.

Been trying to get drush and bee to work in Mamp but not yet successful.

I've finally got drush to work in Mamp somehow and successfully updated dbase! Still have no idea about the blank screen though...

But perhaps I'm using the DevDesktop drush that ends up with this response:

CiviCRM requires PHP 7.2.0+. Drush is running PHP 5.5.38.

The civicrm module become disabled in the Module List UI, which I enabled it back.

A sidetrack question to this... earlier on, I attempted to install another drush via cgr command, but when I check "which drush", it doesn't point to the newly install .composer/global/drush and still the old /Applications/DevDesktop/tools/drush  So to avoid complication I uninstall it earlier, continued with finding ways to get the DevDesktop drush to work in Mamp.

If I install the new drush again, how should I get it to work separately from the DevDesktop drush? I usually access it via DevDesktop UI.

Or update that to php 7.3?

Current .bash_profile is:

source ~/.profile export PATH="$PATH:/Applications/DevDesktop/tools" export PATH="$PATH:/Applications/DevDesktop/drush_9" export PATH="$HOME/.composer/vendor/bin:$PATH" export PATH=/Applications/MAMP/Library/bin/:$PATH

Current .bashrc is:

export PATH="$PATH:/Applications/DevDesktop/tools" export PATH="$PATH:/Applications/DevDesktop/drush_9"

# export PATH=$PATH:$HOME/.composer/vendor/bin export CGR_BIN_DIR=$HOME/.composer/vendor/bin

indigoxela's picture

CiviCRM requires PHP 7.2.0+. Drush is running PHP 5.5.38.

Ooops, you're using PHP 5.5? Wait, what's the php version displayed on your status page (admin/reports/status)?

Hi indigoxela, it's showing Version: 7.3.24 for Backdrop php.

What I mean is the line in terminal seems to suggest that the drush I'm using in /Applications/DevDesktop/tools/drush is still 5.5.38 that comes with DevDesktop (I'm guessing drush is running on some php? sorry I'm not competent technically, hope I'm not confusing you further... 😅).

indigoxela's picture

Ah, OK, you have php 5.5.38 on command line (yes, drush needs php), but have php 7.3 for your Backdrop - probably with mod_php (and Apache).

You seem to have managed to run the updates, is that correct?

No more nagging on your status page and your install is working fine? Nothing in your dblog (admin/reports/dblog)?

Then maybe your problem is fixed. Sorry that we couldn't provide more help with your MAMP.

Yes the update is done via drush, which is not quite an ideal setup yet. Hence I'm asking in about further question on second drush setup. 

But anyway, it seems working fine in my local setup. Hopefully I can do normal UI update in production.

Thanks for the help! :)

indigoxela's picture

Hopefully some other MAMP user can provide more info on how to setup drush on it. I'm not sure, though, how many of them are here in the forum.

Ok noted, looks like I should use lando with Backdrop? Will pick that up. I'm just conveniently using Mamp since my last few wordpress projects.


indigoxela's picture

I'm just conveniently using Mamp since my last few wordpress projects.

That should work fine, too, also with Backdrop - in theory. Lando might be a good option. I know there are several people here that use it and could provide some help.

CiviCRM is a little bigger than a normal Wordpress page. I have seen it being referred to as "the tail that wags the dog". :-) So maybe it's just a bit too "hungry" for your MAMP setup? Not sure. (You increased all sorts of limits, though, as you posted in your initial question.)

The site I'm working on was from Drupal7 without Civicrm, which I've been using DevDesktop. Took the leap recently to migrate to Backdrop and add Civicrm as the NPO requirements grow. It's ok in local dev using Mamp, until I follow the good practice suggestion to install Civicrm into different dbase 😅 More hurdles to go through, but I'm already seeing the benefit of doing so. 

Also to clarify, I actually change the limits back to default as it didn't help the blank screen issue. The site is still hosted in a shared hosting environment, so I thought set it back to default can help to surface other issue early in local dev.

Totally understand your simile of "the tail that wags the dog" 😊

Thanks again for your advice.