I can't seem to get the [node:author] token to work. It's for a content type that does not have an added field for the author, but instead relies on the "Authored By" default when the content is created.  The token appears in the list of available tokens, but when I try to save it in one of the metatag fields, I get the error: "The Page title is using the following invalid tokens: [node:author]" . So, I put it into the specific content type's metadata in the summary field as such: by [node:author] | [node:summary] . That doesn't work either.  I just want the author's name to show up when a link to their content is shared.

Modules installed: Entity Tokens 1.x-2.0.4 Token Filter 1.x-1.0.2 Token Help 1.x-1.1.3 Fast Token Browser 1.x-1.5.3 Entity Plus 1.x-1.0.19 (not sure if this is relevant here)




Be sure you are inserting this token in a metatag that has "Content" as context. 

I have it there, and even tried moving it to the specific content type, but still can't get it to work.

Thought it might have been because  "Display author and date information" was unchecked in the content type, but that didn't make a difference. Can't get the author's name to show on any content type. 

Here's my config. under CONTENT:

Page title: [node:title] | [node:author] | [site:name]

Description: [node:summary]

Canonical URL: [current-page:url:absolute]

Content title: [node:title] 

Content description:[node:summary]

Metadata for my Drupal site is also complicated, but seems to have a simpler interface.  I'll set it aside and have another look tomorrow.