To start off let me say THANK YOU for an awesome system!

I have a system running at https://jacagezone.co.za/. There were upgrades due, so I put the website/system in maintenance mode as I always do for the upgrade.

As far as I'm aware the update was completed successfully. However, the website is stuck in maintenance mode and whatever I try, I'm unable to get it out. I'm currently on the point of rebuilding it, luckily it seems that the module is still there.

Does anybody have any advice or something for me to try here? It'd be nice.

Thank you,

Most helpful answers

Thank you. this has at least given me some hope that it could be fixed!

I really don't know why I haven't done this earlier (oh right, it was the maintenance mode thing)

When I manually disable it, I get a blank page. In the logs I get this error.

Cannot redeclare node_path_info() (previously declared in /home/jacagezo/public_html/core/modules/path/path.path.inc:16) in /home/jacagezo/public_html/core/modules/node/node.path.inc on line 44\n

I haven't done anything that could case this. Or at least not on purpose. It is a step closer to finding out what the problem is.

At least update.php is complete, and no changes are necessary. I'll re-upload the CMS now, to see if that helps any. Not that I haven't tried that already.

UPDATE:

I have just deleted and then re-uploaded the core/ directory again. Now everything seems to be working.

THANK YOU! THANK YOU! THANK YOU!

In phpmyadmin or otherwise, go to the state table, find maintenance_mode, click BLOB, open the blob file that downloads, edit it in an editor, change 0 to 1, save the file. Then click edit next to maintenance mode again, and upload the saved file. At least that should get you out of maintenance mode. Youll need to flush caches, which you could do either by clearing the cache table or visiting update.php again.

If you can install Devel module, you can run (in the PHP block):

state_set('maintenance_mode', FALSE);

 

Comments

Don't rebuild it yet.

I'm pretty confident that we ought to be able to provide some options for you. It would be helpful for you to be explicit about anything that you have tried already, to save us time. Even the obvious. 

What happens when you uncheck the "maintenance mode" checkbox at /admin/config/development/maintenance ?

Have you tried clearing the cache?

(Always try clearing the cache, even if it makes no sense at all. Especially, if it makes no sense at all.)

Also, it would be helpful if you tell us your experience level and hosting. Are you comfortable/able to use phpMyAdmin (or another too) to make a direct change to the database, if necessary?

What kind of hosting are you using?

What version of backdrop are you using (what did you upgrade when you put the site into maintenance mode)?

 

Hi stpaultim,

Thank you for your reply, I really do appreciate it.

I'm using normal shared hosting, so I don't have SSH. I know that probably would have helped.

I'm OK with using phpmyadmin to do something. No problems there.

I cannot remember what version of backdrop it is, unfortunately. I can assure you it's no older than 5 releases, though.

I am unable to get into the back end at all so cannot uncheck the maintenance mode box at the moment, or do anything else for that matter.

The cache was cleared recently, but as I mentioned above, I am unable to do anything in the back end. I have truncated the cache_* tables with phpmyadmin, though.

When I browse to the user/login page, I get the login form. Upon submitting the login I am redirected to a blank page. When I browse to user/login again I get the login form again. So it doesn't seem to even do the login.

When I browse to the user/login page, I get the login form. Upon submitting the login I am redirected to a blank page. When I browse to user/login again I get the login form again. So it doesn't seem to even do the login.

OK, so your current problem is that you can not login to the site. This may or may not have anything to do with maintenance mode.

I'm not sure what to try next, but I'll ask around..... :-)

If you can install Devel module, you can run (in the PHP block):

state_set('maintenance_mode', FALSE);

 

Unfortunately that isn't possible for me to do.

In phpmyadmin or otherwise, go to the state table, find maintenance_mode, click BLOB, open the blob file that downloads, edit it in an editor, change 0 to 1, save the file. Then click edit next to maintenance mode again, and upload the saved file. At least that should get you out of maintenance mode. Youll need to flush caches, which you could do either by clearing the cache table or visiting update.php again.

Thank you. this has at least given me some hope that it could be fixed!

I really don't know why I haven't done this earlier (oh right, it was the maintenance mode thing)

When I manually disable it, I get a blank page. In the logs I get this error.

Cannot redeclare node_path_info() (previously declared in /home/jacagezo/public_html/core/modules/path/path.path.inc:16) in /home/jacagezo/public_html/core/modules/node/node.path.inc on line 44\n

I haven't done anything that could case this. Or at least not on purpose. It is a step closer to finding out what the problem is.

At least update.php is complete, and no changes are necessary. I'll re-upload the CMS now, to see if that helps any. Not that I haven't tried that already.

UPDATE:

I have just deleted and then re-uploaded the core/ directory again. Now everything seems to be working.

THANK YOU! THANK YOU! THANK YOU!

Do you have any errors in your server logs after getting the blank page?

Also I noticed that the site works with and without both 'https' and the 'www' in the domain, so double check that you're on the same domain after logging in as you were after. I've seen that happen before where you log in on the secure side (or the site with the 'www') and then get bounced to the other version for some reason (such as a setting in your `settings.php` file), where you are not logged in. The blank screen makes me think this is not the case here, though.

Great! I'm guessing you had accidentally uploaded the core directory into the old core directory rather than replacing it, ending up with a duplicate of everything.

Something like that yes. I honestly don't know. But I AM glad it's sorted now.