Meticulously cleaned D7 database successfully imported to EMPTY DB of fresh Backdrop codebase.

On install, entering db info screen results in "Table variable already exists".

I can push past this screen by entering install.php again, results in:

./sites/PATH_TO_FILES/files/config_LONG_NUMBER_/active directory must be completely empty to proceed with installation. Empty this directory or specify a different directory in settings.php.

Whatever tried, can't get beyond this screen repeatedly. Nothing helpful in logs. I've redone DB, user, + host, watched + tested both locations of settings.php + files (root + multisite), filled out settings.php manually. No luck searching.

Permissions seem good...
settings.php  644 owner
files 755 owner
on either location of these.


EDIT: I did not see that @echo is doing an upgrade, not a new Backdrop install.


@echo - Just a thought. But, are you starting with a fresh database?

If you start the install process, stop and start over, you need to drop all the tables in your database and start fresh. 

At the point you are entering your credentials into the site, your database should not have any tables. 

I don't understand. Following Step 3

This is not install, this is the migration Upgrade.

At the time we run update.php, we have the prepared D7db imported into the just previously EMPTY db of the new BD codebase.

BTW, I was able to install BD the normal way just recently for experimenting, but wiped that + started fresh for this Upgrade.

@echo - I am sorry, I did not read you question close enough. Yes, this is different for an upgrade. 

Are you entering the database credentials into the Backdrop site OR into the settings.php file. 

For an upgrade, you should not be using the Installer - meaning you should NOT be entering any information into the UI at this stage in the process.

Rather, you should be connecting to the database through the settings.php file and then running update.php. See steps #6 and #7.

I hope this is helpful. 

NOTE: We have office hours on Wednesday to help folks with their upgrades.

Or keep asking your questions here.

Thanks for that tip, I'd been doing it both ways, now I've just done a few clean attempts through settings.php and got the same two notices. It is writing to the settings file (got the 'hash_salt'). It is doing some suspicious browser things, like I filled out settings.php in one location, and it wrote to another, and that seems related to the errors. I'm gonna sleep on it now, thanks for your effort.

Any hunches, much appreciated. More attempts with same results.

Pre prepared D7, disabled custom theme, switched to Bartic, imported to empty db of fresh Backdrop codebase.

Entered db info directly to settings.php. Then running update.php in browser gets to the first same notice, "Table variable already exists".

It has written to settings.php + written config_.../active with 4 system [dot] files.

Any clicking further results in second notice (active directory must be empty, see OP above).

Every test:
* Safari + Chrome, clearing caches + relaunching
* copying fresh settings.php + deleting config directories
* one test with sites folder empty

Previously no issue with regular install of BD for experimenting, but wiped that + started fresh for this Upgrade. So it points to the D7 export. Any ideas what to try?

Apologies for so many posts, just wanted to followup.

Resolved (!) by using default single site locations rather than my usual multisite, which I only used on local for ease of one codebase.

Congratulations. Sorry, I couldn't be of more help. 

Thanks for posting the resolution. It's good to know that you solved the problem, maybe your solution will help someone else someday.

You have nothing to be sorry about :-) having your responses go a long way in feeling supported.