Mr. Bunny's picture

Hi folks! =)

This problem has plagued me for a few months already and I can't seem to find any similar cases anywhere.

An attempt to install any update (core or modules) via Backdrop's own web interface results in error:

- Error installing / updating
- File transfer failed, reason //var/www/[module name] is outside of the /var/www/

Here's a screenshot:

This error is present on every Backdrop instance I'm managing, regardless of environment. IIRC this error started showing when core updates via web UI were incorporated into Backdrop (v. 1.12.0). 

I've tried:

  • Fixing file permissions -> no effect
  • Updating the core manually (to 1.12.6) and then updating module(s) via web UI -> no results
  • Using different PHP versions (7.1 - 7.3) -> makes no difference

I've also tried installing fresh Backdrop 1.11.4 (last version before enabling core updates), manually installing old version of imagesloaded module, and then trying to update that. This leads to a HTTP 403 error:

Failed to download imagesloaded from

Core versions 1.12.0 and above download modules correctly but fail to install them.

The (test) server is running Debian 9.8, Apache 2.4.25, MariaDB 10.1.37 & PHP FPM. Apache user & group owns all files, PHP FPM has same users.


Does anybody have any idea what to try next? I'm out of ideas.