Tronico's picture

After migrating from Drupal 7 to Backdrop 1.14 I get the following error when I enter a post from any book:

Notice: Undefined index: book_mode en book_block_view() (line 269  /..../core/modules/book/book.module).

I was previously given another error related to books because I had not correctly migrated the configuration of the books module, a tight time gives me the previous error, does anyone know what it can be?

Thank you.

Accepted answer

So you have the correct settings on /admin/content/book/settings now, but the Notice is still there... hm...

Did you already try to flush all caches? (You probably did, but just in case...)

So the problem might be with your default layout settings.

If you go to /admin/structure/layouts/manage/default and open Configure block "Book navigation" - what are the settings for "Book navigation block display"?

If you save that block settings and save the layout afterwards: does the Notice go away?

 

Comments

Hi Tronico,

I didn't migrate any D7 with Book module enabled yet, so I'm just guessing.

If you go to /admin/content/book/settings - what are the settings there? Are these settings correct?

If you save this settings form once - does the Notice go away?

If not: what are the (visibility) settings of the book block (book table of contents)?

Does the book block show up correctly with existing book pages?

Tronico's picture

If you go to /admin/content/book/settings - what are the settings there? Are these settings correct?

The settings were not migrated and I was given an error with a blank screen and an error message, once set it already shows me the books but with the error described above.

--------------------------------------------------

If you save this settings form once - does the Notice go away?

No

----------------------------------------------------

If not: what are the (visibility) settings of the book block (book table of contents)?

They are the ones I had by default in D7

-----------------------------------------------------

Does the book block show up correctly with existing book pages?

Yes, but with the error message.

-------------------------------------------------

Gracias.

So you have the correct settings on /admin/content/book/settings now, but the Notice is still there... hm...

Did you already try to flush all caches? (You probably did, but just in case...)

So the problem might be with your default layout settings.

If you go to /admin/structure/layouts/manage/default and open Configure block "Book navigation" - what are the settings for "Book navigation block display"?

If you save that block settings and save the layout afterwards: does the Notice go away?

 

Tronico's picture
  1. Clean the cache without result.
  2. I save the settings in "Book navigation block display"  without result.
  3. I deactivate the books module and activate it again, without result.
  4. I delete the n"Book navigation block display" and recreate it, AND THE MESSAGE DISAPPEARS

THANK YOU VERY MUCH, you have given me the necessary clue for solution.