Have been developing this site for a month or so, with ability to create Pages with no problems.

But suddenly today I can no longer Save Pages.

I choose Add Content / Page / Enter my title, Body text, etc. and hit SAVE

and I receive the error page:


The website encountered an unexpected error. Please try again later.

When I close the error and check my content list, the new page is not there.

Has anyone else experienced this?


@ - I don't think that this is enough information for anyone to solve your problem. I can ask a few questions that might help others give advice and offer some basic tips for debugging this.


Are you developing the site on your computer or are you working on a remote server?

Any big recent changes to the development environment? Any big changes to the site itself (other than this bug)?

Have you checked the Backdrop log: admin/reports/dblog

Do you have access to error logs on the server/computer?

Have you cleared the cache (sorry, but I always have to ask this)?

Have you tried saving other types of content? Can you create a new user? Can you create a new a tag (admin/structure/taxonomy/tags)?


After running some tests,

all other content can be saved OK.

And the Pages would save OK if I chose a Taxonomy term (I had a field that displayed dropdown selectors of one of my Taxonomy categories).

But if I do not choose a Taxonomy category, then I receive the error window.

That field was not a 'required' field, so it seems strange that it would throw an error when it isn't being used?

And also, would be great if the error could say: "Field name" is requred Instead of just not saving my content and dropping an error page on me

I don't think you are getting a useful error message, because this sounds more like a bug to me. I'm puzzled, because you said it was working fine and then it wasn't. 

This is what I recommend. 

1) You might try to rebuild the content type and see if the new one works. If you are able to delete the old one, then the problem is solved.  If you have too much content to delete the old one, you could try comparing the config file for the new one vs the config file for the old one. Maybe something got messed up in the config. I've never seen this happen yet, but it's worth checking.

2) If you are able to recreate the problem in a new content type, you should file a bug report for Backdrop core and provide steps to reproduce the error. 


I'm experiencing the same problems on my relatively new Backdrop 1.13.2 site (with a few contrib modules installed, but not tons.)

The errors don't happen 100% consistently, but they're persistent and won't go away; I can try to nail down a particular pattern to when it does or does not happen.

I'm experiencing the same thing as @ - if I try to create a new page or post and don't select a taxonomy term for either of my term reference fields, which aren't required, I get "The website encountered an unexpected error. Please try again later." If I select taxonomy terms in both fields, the node saves properly. I can then edit the node, deselect the terms in either or both fields and save again with no problems.

The errors in the database log:

PDOException: SQLSTATE[23000]: Integrity constraint violation: 1048 Column 'tid' cannot be null: INSERT INTO {taxonomy_index} (nid, tid, sticky, created) VALUES (:db_insert_placeholder_0, :db_insert_placeholder_1, :db_insert_placeholder_2, :db_insert_placeholder_3); Array ( [:db_insert_placeholder_0] => 35 [:db_insert_placeholder_1] => [:db_insert_placeholder_2] => 0 [:db_insert_placeholder_3] => 1564709074 ) in taxonomy_build_node_index() (line 2013 of /var/www/dev/site/public_html/core/modules/taxonomy/taxonomy.module).


EntityStorageException: SQLSTATE[23000]: Integrity constraint violation: 1048 Column 'tid' cannot be null in NodeStorageController->save() (line 487 of /var/www/dev/site/public_html/core/modules/node/node.entity.inc).

Ah--this seems an awful lot like what @laryn describes in https://github.com/backdrop/backdrop-issues/issues/3913. I'm going to add all of this to that issue!