bugfolder's picture

I see that notice appearing in the dblog even with anonymous webform submissions, so I don't think that's related to your problem. [Update: turns out it is, see below.]

Can you say a bit more about the specifics: is your anonymous or authenticated user getting denied access to the form itself, or does the problem happen upon submission?

bugfolder's picture

By the way, about that warning: one way it is generated is if the default "from" address isn't filled in in the Webform settings at admin/config/content/webform.

bugfolder's picture

Let's try to clear up the "Notice: undefined index" warning. (I can't follow your link, of course—which is as it should be.) Would you confirm that on the page at admin/config/content/webform, you have entered the "Default email values"? 

Entering a default value does fix the error..thanks, and now any role can submit.

But submissions are always seen as coming from the default email address rather than the submitter's email address.

I need the reply to the address to belong to the sender has always worked with my Drupal sites.


bugfolder's picture

Let's just check something: in the E-mails settings for the webform,

  • you've set the "E-mail reply-to address" to "Component", with the component that contains the submitter's email address.
  • you've set the "Email reply-to name" to "Component", with the component that contains the submitter's name.

In that case you should have the from header of the email being "Submitter Name via From Name" <>", and the reply-to header being "Submitter Name <>".

What differences from that are you seeing?

The reply to header is always the default site email address.

I am wondering if this is related to smtp settings ..I am using sendgrid

I have other Drupal 7 sites that work perfectly with webform..let me take a look.

I will leave you in peace (for a while)

So grateful for your support









Wow ..I am not alone.


Very very grateful for your input!!





I use "Your email address" for the person submitting the form...

The on the "E-Mails" tab, set the "Email Reply-to address" to the "Your email address" field.

Hope this helps.